coolsky-super-80-fsx-steam-edition

Calling all Mad Dog drivers! Hotfixes to make the Super 80 Classic and Super 80 Professional compatible with FSX: Steam Edition have now been released.

Please note that these hotfixes only make the Super 80 Classic and Super 80 Professional compatible with FSX: Steam Edition. These hotfixes do not contain any upgrades or fixes beyond making the products compatible with FSX:SE. If you do not fly your copy of the Super 80 Classic or Super 80 Professional in FSX: Steam Edition, then you don't need any of these updates.

You can read more about and download the Super 80 Classic or Super 80 Professional hotfixes for FSX:SE from the Development section of the support forum.

 

Support Forum (Super 80 Classic)

Support Forum (Super 80 Professional)